Adresa IP primita de la ISP nu poate fi ping-uita


#1

Salutare tuturor, ma aflu intr-o dilema si nu-mi dau seama daca internetul a luat-o razna avand in vedere ca cica luna trecuta s-a alocat ultimul bloc de adrese IPv4, ISP-ul meu a facut ceva modificari sau s-a intamplat ceva la mine local. Am nevoie de niste clarificari ca am mai uitat si eu din ele.

Dilema a inceput in momentul in care am vrut sa ma joc cu un prieten un multiplayer unde hostam serverul la mine, doar ca eu sunt in spatele unui router wireless (prin el ma conectez la ISP). No big deal, am facut ce am mai facut si in trecut de multe ori: am intrat in interfata routerului si am setat un port forwarding si apoi i-am dat adresa de WAN colegului.
Colegu’ nu se poate conecta.
Il rog pe coleg sa-mi dea un ping la adresa prezentata pe pagina de status a routerului. 100% packet loss.
Restartez router. Nimic. Observ ca pe servicii “what’s my ip” imi apare alta adresa. Nici aia nu e ping-uibila.
Bag cablu de net direct in PC. Pe ipconfig /all imi apare un adapter virtual PPPoE cu o adresa si adapterul Ethernet cu alta (iar “what’s my ip” da o alta…), ma gandesc ca adresa aia PPPoE e cea corecta. Nici cu asta nu merge. De data asta pe servicii “whats my ip” imi apare si adresa IPv6.

Incerc sa folosesc terminal emulator pe telefon si sa pinguiesc toate variantele. Nope. Instalez un programel Packet Sender si incerc sa trimit catre el pachete UDP/TCP. Nimic.

Activez serviciul DDNS de la ISP si incerc iar sa dau pinguri (in ping de pe telefon daca dau adresa DDNS imi afiseaza IP-ul corect), sau sa trimit pachete, sau sa accesez un server web hostat local. Nada. Das ist Kaput!

Ce se intampla? S-a schimbat ceva in ultimul timp in cum functioneaza ISP-urile? Din cate stiu IP-urile de NAT sunt cele cu 192, 10 si 172, adresa aia WAN primita de la ISP ar trebui sa fie accesibila si vizibila pe net nu?


(Eduard-Dan Stanescu) #2

Si eu am exact aceeasi problema cu RDS-ul.
ONT-ul nu primeste adresa externa decat foarte rar (188…), in rest am IP ceva cu (100…), iar daca intru pe google sa vad ce adresa am imi zice ca e (82…).
Am pus si ONT-ul in bridge, ca sa imi folosesc propriul router si la fel.
Trebuie sa sun la ei sa vad care e faza, ip-ul ala cretin nu duce nicaieri, nu inteleg ce se intampla.

Acum vad ca am ip cu 188, e extern.


(Serghei Amelian) #3

Dacă îţi apare adresa diferita pe google cand cauti “my ip”, cel mai probabil au făcut NAT. Clasa e irelevantă, e o simplă convenţie că IP-urile private încep cu 192, 10 sau 172, în practică poţi să faci NAT la ce clasa vrei, ruterului nu-i pasă oricum.


(Eduard-Dan Stanescu) #4

Pai si eu ce fac ? Am nevoie de ip extern pentru localhost, demo-uri, preview-uri.


#5

Exista ngrok sau localtunnel pentru tunneling dar e o grija nenecesara in plus cand platesti servicul asta. Ce ma deranjeaza mai tare e ca au serviciul de DDNS dar nu functioneaza! Mi se pare o schimbare recenta, pana nu demult functiona treaba asta.


(Serghei Amelian) #6

Păi ei nu cred că sunt obligaţi să-ţi asigure “incoming”-ul. Din câte ţin minte, pe la începuturi unii provideri chiar interziceau explicit “incoming”-ul, îl tăiau pur şi simplu din firewall.

O rezolvare mai îmbârligată poate fi un VPN între ruterul tău de acasă si un VPS aflat undeva în internet şi să redirectezi traficul de pe unul din porturile VPS-ului spre serverul tău de acasă.


(Eduard-Dan Stanescu) #7

Ngrok merge ca melcu + sunt probleme cu path-ul, depinde cum faci aplicatia.

Am vps-uri, hosturi cumparate, dar ziceam asa ca chestie, pe localhost imi era mai usor, decat sa stau sa urc mereu. Mersi oricum.

Sun maine la ei, vedem daca este normal ce fac ei.


(Serghei Amelian) #8

Păi dacă ai VPS-uri, e foarte simplu de rezolvat. Îţi iei un router oarecare care ştie OpenVPN (de exemplu orice router Mikrotik ştie asta, cel mai ieftin este sub 100 RON), instalezi OpenVPN pe unul din VPS-uri, conectezi routerul la VPS, faci portforwarding dinspre VPS spre serverul web (sau ce ai acolo) de acasă şi cu asta basta.


(István F.) #9

Ce router ai ? Aveti ?
Daca ai un router de la RDS singurul mod in care il faci sa mearga cu port forwarding e sa suni la ei sa ti-l seteze. (sau daca ai routerul integrat in ONT)

Daca aveti ONT iarasi trebuie sa sunati ca sa va dezactiveze routerul integrat ca sa va puteti folosi propriul router. (pe care faceti port forward in mod obisnuit si va conectati cu pppoe) Dar cred ca pot seta ei port forwarding-ul la routerul integrat. (tu nu poti, nici macar cu contul de admin sau merge doar la anumite routere)

Un alt truc: Daca intrati in contul digi de pe digicare puteti sa va setati un dns dinamic sub forma nume.go.ro care va duce mereu la ip-ul pe care il are ONT-ul. (dar tot este necesar port forwarding si setare DMZ)


#10

Routerul este TP-Link. Nu am ONT, e Ethernet.

Un alt truc: Daca intrati in contul digi de pe digicare puteti sa va setati un dns dinamic sub forma nume.go.ro care va duce mereu la ip-ul pe care il are ONT-ul. (dar tot este necesar port forwarding si setare DMZ)

Am facut si asta, am scris mai sus :).


(István F.) #11

Atunci daca te logezi cu pppoe in routerul tau inseamna ca poti sa iti setezi linistit port forwarding pe porturile pe care vrei sa le ai deschise.

Nu uita sa permiti accesul si din firewall-ul din windows.


(Eduard-Dan Stanescu) #12

Tocmai ce am scris ca l-am trecut in bridge, utilizand portul 4 al ONT-ului. Deci nu trebuie sa sun la ei pentru asta. Daca era inchis portul 4, atunci sunam la ei.
Port forwarding fac si pe ONT si pe router-ul meu, dar merge doar cand imi aloca ip extern in WAN.


(István F.) #13

Portul 4 parca era pentru IPTV daca imi amintesc bine, nu e bridge pentru internet.


(Eduard-Dan Stanescu) #14

Eu stiam ca este pentru bridge portul 4. Voi suna maine la ei, vedem ce pot rezolva.

Conectare Deconectare Durată IP MAC Download Upload
05.05.2018 00:30:05 06.05.2018 00:30:01 23h:59m:56s 188.25.37.218 b0:48:7a:e2:1a:f1 2.10 GB 224.00 MB
04.05.2018 05:13:41 05.05.2018 00:30:05 19h:16m:24s 100.98.39.186 b0:48:7a:e2:1a:f1 0.00 B 0.00 B
04.05.2018 00:30:04 04.05.2018 05:13:41 04h:43m:37s 100.98.12.37 b0:48:7a:e2:1a:f1 0.00 B 0.00 B
03.05.2018 00:30:04 04.05.2018 00:30:01 23h:59m:57s 100.98.18.47 b0:48:7a:e2:1a:f1 885.00 MB 167.00 MB
02.05.2018 00:30:05 03.05.2018 00:30:01 23h:59m:56s 100.98.1.170 b0:48:7a:e2:1a:f1 1.18 GB 104.00 MB
01.05.2018 00:30:05 02.05.2018 00:30:01 23h:59m:56s 5.12.159.218 b0:48:7a:e2:1a:f1 4.58 GB 147.00 MB
30.04.2018 00:30:04 01.05.2018 00:30:01 23h:59m:57s 188.25.74.46 b0:48:7a:e2:1a:f1 1.59 GB 96.00 MB

IP-urile cu 100 nu sunt externe.


(Opencart Romania) #15

Salutare!

Cred ca e mai complicat sa ‘tot alergi dupa IP’, vezi ca DIGi iti pune la dispozitie un subdomain name, care iti va pointa in subnet-ul tau.

Restul rezolvi din router-ul local.

Problema cu ping, din cate stiu au disable ‘icmp-ul’, posibil sa ma insel, insa trebuie sa retii ca acel IP va fi dinamic…, deci nu-l vei gasi / pointa de fiecare data…

Mai mult, sa-ti deschizi zona de dev catre intenet, presupune si ceva cunostinte de secu…

Spor, sper ca am mai facut ceva lumina, solutia completa, difera de la caz la caz…


(Eduard-Dan Stanescu) #16

Nu ai inteles nimic, ti-ai stins becul singur. :slight_smile:
Nu ai ce sa rezolvi din router-ul local cand primesti un IP ce nu este public / extern.
Nu alearga nimeni dupa IP-uri.
Cunostinte sunt multe.


(Andrewcpp) #17

IP-urile cu 100 le primiti pentru ca IP-ul vostru este rutat in spatele altui IP. Din acest motiv nu va merge nici sa faceti port-forwarding.

Rezolvarea este simpla: sunati la ei si le explicati acest lucru. Ei vor activa functia “opt-out” si o sa va mearga.

@zshare Stii tu ceva dar nu stii bine. Este vorba de IP-urile intre 100.64.0.0 si 100.127.255.255 care sunt rezervate pentru CGN. Si un IP pe care il primesti, de oriunde altundeva in afara de router-ul tau, este public. Doar router-ul iti poate da prin DHCP ip privat.