Pentru ce browsere livrati site-uri/ back-enduri

Eu pentru backend livrez pentru versiunea curenta de browser.

Pentru site-uri, ultimele 2 versiuni de browser.

Având în vedere că toate browserele oferă update automat, ofer suport doar pentru ultima versiune stabilă.

Pentru IE ofer suport pentru ultima versiune stabilă iar pentru versiunile anterioare cer câte un procent din prețul final, dublând pentru fiecare versiune: 10% IE10, 20% IE9, 30% IE8 etc; pentru IE7, cer aproape dublu: 75% extra). Scopul evident fiind acela de a filtra clienții care chiar au nevoie de IE7 vs cei care cred că au nevoie.

Un criteriu foarte important de a stabili cât de important este versiunea browserului constă în statisticile site-ului (de cele mai multe ori am parte de redesign).

Pentru backend nu-mi bat capul; folosesc exclusiv WordPress :smile:

http://dowebsitesneedtolookexactlythesameineverybrowser.com/ :dash:

Eu nu testez niciodata pe IE, si in general am un mesaj in care ii rog pe useri sa isi puna un browser in loc de IE.

Chrome ma ajuta cel mai mult la development si mai testez si pe Firefox si Safari

Cred că-s cel mai napastuit de pe aici… trebuie să suport IE8 :expressionless:

Partea bună e că nu e chiar așa de rău, cred că in total am scris maxim 50 de linii de css special pentru IE8, în rest dacă ai HTML/CSS bun și nu ai așteptări foarte mari… IE8 merge.

PS: @iamntz nu știu ce e emoticolul ăla de-l tot folosești, dar să ști că în mintea mea e un… pârț (ca să nu-i zic altfel ;P)

:dash:. Asta și vrea să fie!

Nu ești singurul năpăstuit. Chiar zilele trecute am terminat un proiect ce trebuia să meargă și pe IE8. Cu parallax, animații etc. Am insistat să renunțe la efecte (dacă nu la IE8). Nu au vrut. Rezultatul? Un site ce merge foarte, foarte greu pe IE8 (deh, nu avem requestAnimationFrame…)

1 Like