Problema instalare phpmy admin pe vps cu centos 7 - Rezolvat


(Cosmin Popescu) #1

Salut !

Am o mica mare problema cu instalarea phpmyadmin pe un centos 7 in sensul ca primesc erori la verificarea de dependinte
php72w-common conflicts with php-common-5.4.16-43.el7_4.x86_64

Eu am instalat php72 + toate cele necesare
In plus am instalat si repo-urile extra(remi si epel), dar tot nu am reusit sa instalez phpmyadmin

Are cineva o sugestie ? :slight_smile:


Conflicte de dependinte


(Ionuț Staicu) #2

Păi dezinstalează php 5.4 :slight_smile:

https://www.centos.org/forums/viewtopic.php?t=56604


(Cosmin Popescu) #5

Nu este instalat !

Oricum o sa vad ca poate a ramas pe undeva vreun fisier etc

Merci pt sugestie


(Serghei Amelian) #6

Pai vezi ce zice daca ii rulezi yum erase php-common


(Cosmin Popescu) #7

Foarte ciudat !
Am rulat acea comanda si dadea tot aceeasi eroare. Am sters php-ul complet cu yum remove si am reinstalat php, dar versiunea 5.4, iar apoi phpmyadmin si a functionat

De asemenea versiunea de phpmyadmin este veche. 4 4 15


(Serghei Amelian) #8

Vezi sa nu uiti sa restartezi apache dupa instalarea sau update-ul php-ului.


(Cosmin Popescu) #9

yep !
Este un lucru obligatoriu. Mai intai trebuie sa editez prin .htaccess


(Andrei Avram) #10

Ai opțiunea de a folosi un container de Docker?


(Cosmin Popescu) #11

Eu am acel vps la Digital Ocean
Pana la urma am distrus droplet-ul si am creat altul nou :slight_smile:

Este optiunea docker la one click apps


(Andrei Avram) #12

Există container de phpmyadmin gata făcut. Eviți orice probleme.


(Cosmin Popescu) #13

Pana la urma am rezolvat complet problema. Am distrus droplet-ul precedent si amcreat altul cu Ubuntu 16.04

Am impresia ca a fost o problema de versiuni :slight_smile:

Multumesc tuturor pt sugestii
@msd voi lua in considerare si Docker. Momentan nu am lucrat cu el, dar din ce am citit este interesant

O seara faina !


https://blog.andreiavram.ro/isolation/


(Alex) #14

data viitoare mergi pe docker.