Why I Am Actively Going to Drop PHP 5.3 Compatibility

O modalitate interesantă (și indrăzneață) de a impune o migrare la versiuni mai noi de PHP.

4 Likes

Sincer, nu vad de ce as mentine compatibilitatea cu mai mult de 2 versiuni (anterioare) minore ([major].[minor].[patch]-[build]) de php, la proiectele noi. La proiectele existente de pe vremea versiunii X, as intelege sa fie necesar suportul pentru versiunea respectiva, ceva timp, dar nu inteleg de ce trebuie sa scriu aplicatiile noi compatibile cu mai mult de 3 release-uri minore (spre exemplu 7.0, 5.6.15 si 5.5.25) care contin mai mult decat bugfix-uri (adica si feature-uri noi sau modificari).

Adica sunt cazuri in care este nevoie de backwards compatibility, pentru ca este unul din feature-urile aplicatiei, dar cand nu am nevoie sa ma limitez la asa ceva, de ce as face-o?

Edit: Acum am vazut ca am reinviat un topic vechi de un an… poate ar fi o idee sa scrie si anul, la data postarii… you know, ca sa nu dea lumea ressurect aiurea…

1 Like