Aplicatie dezvoltata cu React Native crashuieste pe iOS

Deci, o sa incep cu inceputul.

Acum vreo 3 luni m-am apucat sa scriu o aplicatie de mobil cu React Native. Deoarece am Windows, in toate aceste 3 luni am lucrat doar cu Androidul, urmand la final sa vad ce voi face si cu iOS.
Aplicatia de Android merge fara probleme.

Cand sa ma apuc de build-ul de iOS am dat de servicul celor de la Expo, EAS si am inceput sa lucrez cu el. Am instalat expo-cli pe proiect (nu am lucrat cu expo cat am dezvoltat aplicatia de Android). De builduit se builduieste cu succes, de mers merge pe Expo (testat pe un iPad Air 2), insa cand deschid buildul de iOS crapa dupa splash screen.

Ma gandesc sa fie de la dependinte problema? Cam asta imi arata pe Expo cand builduiesc

[stderr] npm
[stderr] WARN ERESOLVE overriding peer dependency
[stderr] npm
[stderr] WARN ERESOLVE overriding peer dependency
[stderr] npm WARN
[stderr] While resolving: @react-aria/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-aria/[email protected]
[stderr] npm WARN node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs
[stderr] npm WARN   @react-aria/[email protected]"3.0.0-alpha.2" from @react-native-aria/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-aria/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs
[stderr] npm WARN     @react-aria/[email protected]"3.0.0-alpha.2" from @react-native-aria/[email protected]
[stderr] npm WARN     node_modules/@react-native-aria/tabs
[stderr] npm WARN
[stderr] ERESOLVE overriding peer dependency
[stderr] npm
[stderr] WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm
[stderr] WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/@react-native-aria/tabs/node_modules/@react-stately/tabs
[stderr] npm WARN   @react-stately/[email protected]"3.0.0-alpha.1" from @react-native-aria/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs
[stderr] npm WARN
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs/node_modules/@react-stately/tabs
[stderr] npm WARN     @react-stately/[email protected]"3.0.0-alpha.1" from @react-native-aria/[email protected]
[stderr] npm WARN     node_modules/@react-native-aria/tabs
[stderr] npm WARN
[stderr] ERESOLVE overriding peer dependency
[stderr] npm
[stderr] WARN While resolving: @react-types/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN node_modules/@react-native-aria/tabs/node_modules/@react-types/tabs
[stderr] npm WARN   @react-types/[email protected]"3.0.0-alpha.2" from @react-native-aria/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs
[stderr] npm WARN   3 more (@react-aria/tabs, @react-stately/tabs, @react-stately/tabs)
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs/node_modules/@react-types/tabs
[stderr] npm WARN     @react-types/[email protected]"3.0.0-alpha.2" from @react-native-aria/[email protected]
[stderr] npm WARN     node_modules/@react-native-aria/tabs
[stderr] npm WARN     3 more (@react-aria/tabs, @react-stately/tabs, @react-stately/tabs)
[stderr] npm WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-aria/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm
[stderr] WARN
[stderr] node_modules/react-dom
[stderr] npm WARN
[stderr] peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-aria/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-aria/focus
[stderr] npm WARN   @react-aria/[email protected]"3.2.3" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-aria/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-aria/focus
[stderr] npm WARN     @react-aria/[email protected]"3.2.3" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN
[stderr] ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm
[stderr] WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/checkbox
[stderr] npm WARN   @react-stately/[email protected]"3.0.3" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/checkbox
[stderr] npm WARN     @react-stately/[email protected]"3.0.3" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN
[stderr] ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/collections
[stderr] npm
[stderr] WARN   @react-stately/[email protected]"3.3.0" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/collections
[stderr] npm WARN     @react-stately/[email protected]"3.3.0" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/combobox
[stderr] npm WARN   @react-stately/[email protected]"3.0.0-alpha.1" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm
[stderr] WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/combobox
[stderr] npm WARN     @react-stately/[email protected]"3.0.0-alpha.1" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN ERESOLVE
[stderr] overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm
[stderr] WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/radio
[stderr] npm WARN   @react-stately/[email protected]"3.2.1" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/radio
[stderr] npm WARN     @react-stately/[email protected]"3.2.1" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN
[stderr] peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/slider
[stderr] npm WARN   @react-stately/[email protected]"3.0.1" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/slider
[stderr] npm WARN     @react-stately/[email protected]"3.0.1" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm
[stderr] WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]12.1
[stderr] npm WARN
[stderr] node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/tabs
[stderr] npm WARN   @react-stately/[email protected]"3.0.0-alpha.1" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/tabs
[stderr] npm WARN     @react-stately/[email protected]"3.0.0-alpha.1" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm
[stderr] WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/toggle
[stderr] npm WARN   @react-stately/[email protected]"3.2.1" from [email protected]
[stderr] npm WARN   node_modules/native-base
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN
[stderr] peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/toggle
[stderr] npm WARN     @react-stately/[email protected]"3.2.1" from [email protected]
[stderr] npm WARN     node_modules/native-base
[stderr] npm WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-stately/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs/node_modules/@react-stately/tabs
[stderr] npm
[stderr] WARN   @react-stately/[email protected]"3.0.0-alpha.0" from @react-aria/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs/node_modules/@react-stately/tabs
[stderr] npm WARN     @react-stately/[email protected]"3.0.0-alpha.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-native-aria/tabs/node_modules/@react-aria/tabs
[stderr] npm
[stderr] WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-types/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm
[stderr] WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/combobox/node_modules/@react-types/combobox
[stderr] npm WARN   @react-types/[email protected]"3.0.0-alpha.1" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/combobox
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/combobox/node_modules/@react-types/combobox
[stderr] npm WARN     @react-types/[email protected]"3.0.0-alpha.1" from @react-stately/[email protected]
[stderr] npm WARN     node_modules/native-base/node_modules/@react-stately/combobox
[stderr] npm WARN ERESOLVE overriding peer dependency
[stderr] npm WARN While resolving: @react-types/[email protected]
[stderr] npm WARN Found: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^18.2.0" from [email protected]
[stderr] npm WARN   node_modules/react-dom
[stderr] npm WARN     peer [email protected]"^16.8.0 || ^17.0.0-rc.1 || ^18.0.0" from @react-aria/[email protected]
[stderr] npm WARN     node_modules/@react-aria/overlays
[stderr] npm WARN     4 more (@react-aria/combobox, @react-aria/menu, ...)
[stderr] npm WARN 
[stderr] npm
[stderr] WARN Could not resolve dependency:
[stderr] npm WARN peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN node_modules/native-base/node_modules/@react-stately/tabs/node_modules/@react-types/tabs
[stderr] npm WARN   @react-types/[email protected]"3.0.0-alpha.2" from @react-stately/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/tabs
[stderr] npm WARN 
[stderr] npm WARN Conflicting peer dependency: [email protected]
[stderr] npm WARN node_modules/react
[stderr] npm WARN   peer [email protected]"^16.8.0 || ^17.0.0-rc.1" from @react-types/[email protected]
[stderr] npm WARN   node_modules/native-base/node_modules/@react-stately/tabs/node_modules/@react-types/tabs
[stderr] npm WARN     @react-types/[email protected]"3.0.0-alpha.2" from @react-stately/[email protected]
[stderr] npm WARN     node_modules/native-base/node_modules/@react-stately/tabs
[stderr] npm WARN deprecated [email protected]: Please see https://github.com/lydell/urix#deprecated
[stderr] npm
[stderr] WARN deprecated [email protected]: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
[stderr] npm
[stderr] WARN deprecated [email protected]: See https://github.com/lydell/source-map-url#deprecated
[stderr] npm WARN deprecated [email protected]: See https://github.com/lydell/source-map-resolve#deprecated
[stderr] npm
[stderr] WARN deprecated [email protected]: https://github.com/lydell/resolve-url#deprecated
[stderr] npm
[stderr] WARN deprecated [email protected]: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added
[stderr] npm
[stderr] WARN deprecated [email protected]: support for ECMAScript is superseded by `uglify-js` as of v3.13.0
[stderr] npm WARN deprecated [email protected]: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
[stderr] npm WARN deprecated @npmcli/[email protected]: This functionality has been moved to @npmcli/fs
[stderr] npm WARN deprecated
[stderr] @react-native-community/[email protected]: Repository was moved to @react-native-masked-view/masked-view
[stderr] npm
[stderr] WARN deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
[stderr] npm
[stderr] 
[stderr] WARN
[stderr] 
[stderr] deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
[stderr] npm WARN deprecated
[stderr] [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
[stderr] npm WARN

[stderr] deprecated [email protected]: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.

Mai am si alte cateva stderr la Fastlane

▸ --- xcodebuild: WARNING: Using the first of multiple matching destinations:
▸ { platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Any iOS Device }
▸ { platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Any iOS Simulator Device }
▸ { platform:iOS Simulator, id:E4F0A83E-5E75-4C8A-A871-796043E2CD97, OS:16.0, name:iPhone 14 }
▸ { platform:iOS Simulator, id:8CF852C2-D053-4020-A861-01D707EE7C7B, OS:16.0, name:iPhone 14 Plus }
▸ { platform:iOS Simulator, id:FE2944BA-74BD-416E-93BB-3DC56388EF16, OS:16.0, name:iPhone 14 Pro }
▸ { platform:iOS Simulator, id:DD553D4E-CD22-4A2B-B095-50D480238D15, OS:16.0, name:iPhone 14 Pro Max }
▸ { platform:iOS Simulator, id:1F7C3904-A8F9-44F2-B6D0-31F51493EA22, OS:16.0, name:iPhone SE (3rd generation) }
▸ { platform:iOS Simulator, id:12DF1F1F-6206-4BDD-A49F-A0D3456DF497, OS:16.0, name:iPad (9th generation) }
▸ { platform:iOS Simulator, id:45E053AA-59FB-41B7-8DCA-2B11D2392A47, OS:16.0, name:iPad Air (5th generation) }
▸ { platform:iOS Simulator, id:7D6C0D20-8EEC-4074-9347-4F2DED6B610C, OS:16.0, name:iPad Pro (11-inch) (3rd generation) }
▸ { platform:iOS Simulator, id:A30864C0-A249-427B-B2F5-02B94465B342, OS:16.0, name:iPad Pro (12.9-inch) (5th generation) }
▸ { platform:iOS Simulator, id:823E8F2B-3928-438B-877F-E57CBB4D4227, OS:16.0, name:iPad mini (6th generation) }
▸ resolved source packages:
$ xcodebuild -showBuildSettings -workspace ./beloyalapp.xcworkspace -scheme beloyalapp -configuration Release
[stderr] --- xcodebuild: WARNING: Using the first of multiple matching destinations:
[stderr] { platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Any iOS Device }
[stderr] { platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Any iOS Simulator Device }
[stderr] { platform:iOS Simulator, id:E4F0A83E-5E75-4C8A-A871-796043E2CD97, OS:16.0, name:iPhone 14 }
[stderr] { platform:iOS Simulator, id:8CF852C2-D053-4020-A861-01D707EE7C7B, OS:16.0, name:iPhone 14 Plus }
[stderr] { platform:iOS Simulator, id:FE2944BA-74BD-416E-93BB-3DC56388EF16, OS:16.0, name:iPhone 14 Pro }
[stderr] { platform:iOS Simulator, id:DD553D4E-CD22-4A2B-B095-50D480238D15, OS:16.0, name:iPhone 14 Pro Max }
[stderr] { platform:iOS Simulator, id:1F7C3904-A8F9-44F2-B6D0-31F51493EA22, OS:16.0, name:iPhone SE (3rd generation) }
[stderr] { platform:iOS Simulator, id:12DF1F1F-6206-4BDD-A49F-A0D3456DF497, OS:16.0, name:iPad (9th generation) }
[stderr] { platform:iOS Simulator, id:45E053AA-59FB-41B7-8DCA-2B11D2392A47, OS:16.0, name:iPad Air (5th generation) }
[stderr] { platform:iOS Simulator, id:7D6C0D20-8EEC-4074-9347-4F2DED6B610C, OS:16.0, name:iPad Pro (11-inch) (3rd generation) }
[stderr] { platform:iOS Simulator, id:A30864C0-A249-427B-B2F5-02B94465B342, OS:16.0, name:iPad Pro (12.9-inch) (5th generation) }
[stderr] { platform:iOS Simulator, id:823E8F2B-3928-438B-877F-E57CBB4D4227, OS:16.0, name:iPad mini (6th generation) }
Command timed out after 3 seconds on try 1 of 4, trying again with a 6 second timeout...
[stderr] --- xcodebuild: WARNING: Using the first of multiple matching destinations:
[stderr] { platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Any iOS Device }
[stderr] { platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Any iOS Simulator Device }
[stderr] { platform:iOS Simulator, id:E4F0A83E-5E75-4C8A-A871-796043E2CD97, OS:16.0, name:iPhone 14 }
[stderr] { platform:iOS Simulator, id:8CF852C2-D053-4020-A861-01D707EE7C7B, OS:16.0, name:iPhone 14 Plus }
[stderr] { platform:iOS Simulator, id:FE2944BA-74BD-416E-93BB-3DC56388EF16, OS:16.0, name:iPhone 14 Pro }
[stderr] { platform:iOS Simulator, id:DD553D4E-CD22-4A2B-B095-50D480238D15, OS:16.0, name:iPhone 14 Pro Max }
[stderr] { platform:iOS Simulator, id:1F7C3904-A8F9-44F2-B6D0-31F51493EA22, OS:16.0, name:iPhone SE (3rd generation) }
[stderr] { platform:iOS Simulator, id:12DF1F1F-6206-4BDD-A49F-A0D3456DF497, OS:16.0, name:iPad (9th generation) }
[stderr] { platform:iOS Simulator, id:45E053AA-59FB-41B7-8DCA-2B11D2392A47, OS:16.0, name:iPad Air (5th generation) }
[stderr] { platform:iOS Simulator, id:7D6C0D20-8EEC-4074-9347-4F2DED6B610C, OS:16.0, name:iPad Pro (11-inch) (3rd generation) }
[stderr] { platform:iOS Simulator, id:A30864C0-A249-427B-B2F5-02B94465B342, OS:16.0, name:iPad Pro (12.9-inch) (5th generation) }
[stderr] { platform:iOS Simulator, id:823E8F2B-3928-438B-877F-E57CBB4D4227, OS:16.0, name:iPad mini (6th generation) }
Command timed out after 6 seconds on try 2 of 4, trying again with a 12 second timeout...
[stderr] 2023-01-04 11:50:02.153 xcodebuild[4796:16721] Requested but did not find extension point with identifier Xcode.InterfaceBuilderBuildSupport.PlatformDefinition
[stderr] 2023-01-04 11:50:02.153 xcodebuild[4808:16792] Requested but did not find extension point with identifier Xcode.InterfaceBuilderBuildSupport.PlatformDefinition
[stderr] --- xcodebuild: WARNING: Using the first of multiple matching destinations:
[stderr] { platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Any iOS Device }
[stderr] { platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Any iOS Simulator Device }
[stderr] { platform:iOS Simulator, id:E4F0A83E-5E75-4C8A-A871-796043E2CD97, OS:16.0, name:iPhone 14 }
[stderr] { platform:iOS Simulator, id:8CF852C2-D053-4020-A861-01D707EE7C7B, OS:16.0, name:iPhone 14 Plus }
[stderr] { platform:iOS Simulator, id:FE2944BA-74BD-416E-93BB-3DC56388EF16, OS:16.0, name:iPhone 14 Pro }
[stderr] { platform:iOS Simulator, id:DD553D4E-CD22-4A2B-B095-50D480238D15, OS:16.0, name:iPhone 14 Pro Max }
[stderr] { platform:iOS Simulator, id:1F7C3904-A8F9-44F2-B6D0-31F51493EA22, OS:16.0, name:iPhone SE (3rd generation) }
[stderr] { platform:iOS Simulator, id:12DF1F1F-6206-4BDD-A49F-A0D3456DF497, OS:16.0, name:iPad (9th generation) }
[stderr] { platform:iOS Simulator, id:45E053AA-59FB-41B7-8DCA-2B11D2392A47, OS:16.0, name:iPad Air (5th generation) }
[stderr] { platform:iOS Simulator, id:7D6C0D20-8EEC-4074-9347-4F2DED6B610C, OS:16.0, name:iPad Pro (11-inch) (3rd generation) }
[stderr] { platform:iOS Simulator, id:A30864C0-A249-427B-B2F5-02B94465B342, OS:16.0, name:iPad Pro (12.9-inch) (5th generation) }
[stderr] { platform:iOS Simulator, id:823E8F2B-3928-438B-877F-E57CBB4D4227, OS:16.0, name:iPad mini (6th generation) }
[stderr] 2023-01-04 11:50:03.332 xcodebuild[4820:16929] Requested but did not find extension point with identifier Xcode.InterfaceBuilderBuildSupport.PlatformDefinition
Detected provisioning profile mapping: {:"org.reactjs.native.example.beloyalapp"=>"9e5258de-503c-4578-b326-68cfeb598493", :"org.reactjs.native.example.$(PRODUCT_NAME:rfc1034identifier)"=>"*[expo] org.reactjs.native.example.beloyalapp AppStore 2023-01-02T21:20:56.742Z"}

Am incercat totul, ma gandesc ca singura solutie ar fi sa incep un proiect pe curat cu Expo din prima, sa iau fiecare dependinta la puricat si dupa sa mut codul. Daca aveti alte solutii, as fi cel mai bucuros.

Vezi ca la rulare pe device din XCode ai un tab unde i-ti afiseaza erorile de consola, acolo cred ca vei gasi mai multe raspunsuri de ce anume crapa aplicatia.

Nu prea am inteles de ce foloseste Expo acuma pentru iOS daca nu ai folosit de la inceput, ar trebui sa ai exact acelasi proiect facut pe Expo sau nu pe ambele platforme.

Vezi ca la rulare pe device din XCode ai un tab unde i-ti afiseaza erorile de consola, acolo cred ca vei gasi mai multe raspunsuri de ce anume crapa aplicatia.

Nu folosesc macOS, deci nu am XCode.

Nu prea am inteles de ce foloseste Expo acuma pentru iOS daca nu ai folosit de la inceput, ar trebui sa ai exact acelasi proiect facut pe Expo sau nu pe ambele platforme.

Pentru ca pentru Android nu am avut nevoie, pe cand la iOS am avut nevoie pentru a folosi serviciul EAS al celor de la Expo.

Recomandari:

  1. Fixeaza versiunile la pachete, nu folosi ^versiune.
  2. Posibil ai ceva proxy la npm si nu poate lua pachetele pe EAS sau e o versiune veche de node/npm.

Poti cumpara cateva ore pe o masina remote cu Mac OS si sa construiesti proiectul local, poate gasesti problema mai usor.

1 Like

Ma gandeam la varianta cu luat un VM.

Sincer, cred ca e vraijste tot proiectul pe parte de dependinte, ma gandeam sa incep un proiect clean direct pe Expo si sa mut functionalitatile pas cu pas, nu cred ca mi-ar lua mai mult de o zi…

Cam o sa ai nevoie, ios device si mac pentru dezvoltare.
Un VM nu o sa te ajute daca sunt probleme la care sa faci debugging pe device doar la cele de simulator o sa fie util.

Mai poti incerca cu o chestie de genul (nu am folosit pana acuma)

sa accesezi logurile de consola de pe device-ul iOS.

Daca doar pentru build ai nevoie de Expo si nu ai inceput cu Expo de la inceput recomand sa te uiti peste alte solutii pentru partea asta cum ar fi:

  1. AppCenter
  2. Bitrise

Subscriu. Mențin un proiect ReactNative și este foarte sensibil la versiunile dependențelor.

Este o idee bună să ții sub control și versiunile de node de pe mașina ta, recomand nvm => GitHub - coreybutler/nvm-windows: A node.js version management utility for Windows. Ironically written in Go.